Spring-boot 2 이제 JUnit5 지원한다.

정확하게 이야기하면 Spring-boot 2.2 버전부터. 이전에 JUnit5를 Spring-boot 2.x 버전에서 사용할 수 있다고 글에서 봐서 써볼려고 했다. 하지만 Surefire 관련된 dependency가 해결이 안되어 있었다. 이걸 기억해서 매번 그걸 exclude 시킬 수는 없는 노릇. JUnit4에서 테스팅 framework의 고전이 걍 끝났나 싶었다. 더 이상 뭘 한다는 이야기를 못들어서. JUnit5 이야기를 듣고, 반갑긴 했지만 결국에는 제대로 써먹기에는 무리! …

Continue reading ‘Spring-boot 2 이제 JUnit5 지원한다.’ »